When working with your routers on your Cisco network, it's very likely that you'll want to have your routers route data. The first step in having your router pass data from one interface to another interface is to enable routing; just use these commands.
Router1>enable
Router1#configure terminal
Router1(config)#ip routing
Whether or not you choose to use a dynamic routing protocol, you may add static routes to your router. The following will add a static route to Router1 to send data to the 192.168.5.0/24 network using the router with the IP address of 192.168.3.2.
Router1>enable
Router1#configure terminal
Router1(config)#ip routing
Router1(config)#ip route 192.168.5.0 255.255.255.0 192.168.3.2
Managing routing information protocol for Cisco networking
Routing Information Protocol (RIP) is widely used, with version 2 allowing you to use Variable Length Subnet Masks (VLSM) across your network. The following code will enable routing, enable RIP, set RIP to version 2, disable route summarization, defines the distributed network from this router as 192.168.5.0/24, and rather than broadcasting routes, it will send RIP data directly to 192.168.1.1.
Router2>enable
Router2#configure terminal
Router2(config)#ip routing
Router2(config)#router rip
Router2(config-router)#version 2
Router2(config-router)#no auto-summary
Router1(config-router)#network 192.168.5.0
Router2(config-router)#neighbor 192.168.1.1
Managing enhanced interior gateway routing protocol for Cisco networking
Enhanced Interior Gateway Routing Protocol (EIGRP) is the updated version of IGRP. The following code will enable EIGRP using an autonomous-system (AS) number of 100, distribute two networks and disables auto summary.
Router2>enable
Router2#configure terminal
Router2(config)#ip routing
Router2(config)#router eigrp 100
Router2(config-router)#network 192.168.1.0
Router2(config-router)#network 192.168.5.0
Router2(config-router)#no auto-summary
Managing open shortest path first for Cisco networking
Open Shortest Path First (OSPF) is a link state protocol which is widely used. OSPF uses the address of the loopback interface as the OSPF identifier, so this example will set the address of the loopback interface, then enable OSPF with a process ID of 100, and distributing a network of 192.168.255.254 and a network of 192.168. 5.0/24
Router2>enable
Router2#configure terminal
Router2(config)#interface loopback 0
Router2(config-if)#ip address 192.168.255.254 255.255.255.0
Router2(config-if)#exit
Router2(config)#router ospf 100
Router2(config-router)#network 192.168.255.254 0.0.0.0 area 0
Router2(config-router)#network 192.168.5.0 0.0.0.255 area 0
Popular Posts
-
OSI Model Explained Summary:Definitions and Functions The Open Systems Interconnect (OSI) model has seven layers. This article des...
-
After setting up any routing protocol that you want to implement - RIP, OSPF, or EIGRP - you can view all of your routing information throug...
-
1 As system administrator, you type "debug ipx sap" and receive the following lines as part of the IOS response: type 0x4, &qu...
-
Networking Questions : Questions on OSI Model with answers [PDF] Q1- What does the acronym OSI stand for? Ans- Open System Interconnec...
-
Some Best Routing CCNA Examination Answers Exams solutions What is the correct order for PDU encapsulation? Frame Header-Network Hea...
-
isco certification ,class ccna, certification books ,new cisco ccna ,ccna study guides, cisco voip training ,cisco courses ,london ccna ,exa...
-
OSPF,IGRP ,EIGRP Multiple Choice Questions 851. What is the extended IPX access list range? A.) 901-1000 B.) 100-199 C.) 900-999 D.)...
-
101 What IP command would you use to test the entire IP stack? A.) Stack-test
-
201 Identify the 3 methods routers learn paths to destinations? A.) Dynamic routing B.) None of the above,
-
CCNA rev 6 © 2008 Cisco Systems, Inc. All rights reserved. Cisco Public 1 APJ Online CCNA Tutorial Session 1 of 3 23rd Feb 2009 APAC &am...
Post a Comment